Back to overview
Resolved
Premium finance options and estimates unavailable
Oct 6, 2025 at 4:15pm UTC
Affected services
API
Checkout
Dashboard
Resolved
Oct 6, 2025 at 4:15pm UTC
Outage with 3rd party financing partner caused downtime on availability of premium finance option on newly quoted programs and unavailability of finance estimate API from 5:00 AM PST - 9:15 AM PST.
Re-quoting on affected programs was completed by 10:15 AM PST.
Additional remediation put in place includes fallback finance quoting for programs in production.
We apologize for the inconvenience caused to you, your team, and your insureds and will look at further measures we can put in place to avoid future issues.
Affected services