Back to overview
Resolved
Service outage
Nov 18, 2025 at 5:25pm UTC
Affected services
API
Checkout
Dashboard
Resolved
Nov 18, 2025 at 5:25pm UTC
Our DNS provider, Cloudflare, experienced an outage around 3:48AM PST lasting 3 hours until 6:34AM PST. This was causing all of our services to be either unresponsive or intermittent.
As of now, our services are operational and we are closely monitoring the situation and investigating the impact during this downtime.
Affected services