Premium finance adjustments and finance estimates unavailable
Resolved
Jan 29, 2026 at 8:50pm UTC
Finance estimates and loan payoffs have been restored.
Affected services
Updated
Jan 29, 2026 at 1:29am UTC
Partial restoration of services - users are able to adjust loan terms.
Affected services
Updated
Jan 28, 2026 at 10:46pm UTC
We are still waiting on a resolution, another update will be provided near end of day.
Affected services
Updated
Jan 28, 2026 at 8:31pm UTC
Our vendor is still working to restore service, another update will be provided at 2:00 PM PST.
Affected services
Updated
Jan 28, 2026 at 4:40pm UTC
We are continuing to work with our vendor to restore full service. We will provide another update at 12 PM PST. In the meantime, we want to assure you that no late fees will be processed during this time.
Affected services
Created
Jan 27, 2026 at 1:56pm UTC
We are currently experiencing an outage with a 3rd party financing partner beginning 5:56 AM PST. This is affecting access to premium finance adjustments, finance estimates API, and any loan-related actions including loan payoffs and notice of cancellations. New quotes and endorsements will still be offered finance terms.
We apologize for the inconvenience caused to you, your team, and your insureds and will provide an update when service is restored.
Affected services